博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
1011 Sticks
阅读量:4698 次
发布时间:2019-06-09

本文共 2031 字,大约阅读时间需要 6 分钟。

1204 Sticks

时间限制:1000MS  内存限制:10000K

提交次数:0 通过次数:0

题型: 外判编程题   语言: 无限制

 

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

 

Sample Input

95 2 1 5 2 1 5 2 141 2 3 40

 

Sample Output

65
 
 
//C++答案代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
bool anUsed[65];
int L,N,stick[65];
bool cmp(int a,int b)
{
     return a>b;
}
bool DFS(int nUnusedSticks,int nLeft)
{
    int i,j,k;
    if(!(nUnusedSticks||nLeft)) return 1;//假如都为0,则拼合完成 
    if(!nLeft) nLeft=L;//新建一个要拼合的棍 
    for(i=0;i<N;++i)
        if(!anUsed[i]&&stick[i]<=nLeft){//剪枝 
            if(i>0&&!anUsed[i-1]&&stick[i]==stick[i-1]) continue;//剪枝 
            anUsed[i]=1;
            if(DFS(nUnusedSticks-1,nLeft-stick[i])) return 1;
           anUsed[i]=0;//可以重新再使用 
            if(stick[i]==nLeft||nLeft==L) return 0;//下一次的递归深入中,刚建了一个新棍,结果后面没有符合条件的棍,
                                                                  //返回这一层时stick[i]==nLeft,而这一层也要返回 
        }            //或者这一层刚开了一个新的棍,但剩余棍中没有符合的棍即nLeft==L,这也需要返回上层 
    return 0;
}
int main()
{
    int i,totalLength;
    while(scanf("%d",&N),N){
        for(totalLength=i=0;i<N;++i){
           scanf("%d",&stick[i]);
           totalLength+=stick[i];
       }
        sort(stick,stick+N,cmp);//一次剪枝 
        for(L=stick[0];L<=(totalLength>>1);++L)
            if(totalLength%L==0){ //二次剪枝 
                memset(anUsed,0,sizeof(anUsed));
                if(DFS(N,L)) break;
            } 
        if(L>(totalLength>>1)) printf("%d\n",totalLength);//三次剪枝
        else printf("%d\n",L);
    }
    return 0;    
}

转载于:https://www.cnblogs.com/arcfat/archive/2012/10/23/2735787.html

你可能感兴趣的文章
preventDefault() 方法 取消事件的默认动作
查看>>
frame.origin和frame.size的心得
查看>>
Fedora17安装SSH
查看>>
mpvue构建小程序(步骤+地址)
查看>>
Android两个控件叠在一起,如何让被挡住的控件显示出来
查看>>
PPT高手博客
查看>>
最小生成树:Kruskal算法 和 Prim算法(第23章)
查看>>
AC-WEB使用HTTPS登录
查看>>
checkbox 的allchose和antichose
查看>>
使用jquery第三方插件(生成曲线图)
查看>>
Django day 36 支付宝支付,微信推送
查看>>
【甘道夫】HBase基本数据操作的详细说明【完整版,精绝】
查看>>
使用BBED恢复数据文件头
查看>>
iOS开发那些事-iOS6苹果地图有用开发
查看>>
JAVA必备——13个核心规范
查看>>
172. Factorial Trailing Zeroes
查看>>
Java语言程序设计(基础篇) 第十一章 继承和多态
查看>>
优秀程序员 分析提高能力 程序进阶
查看>>
javascript 获取图片原始尺寸
查看>>
关于JS中apply和call详细解答
查看>>